PHP 5.6.x < 5.6.32 Multiple Vulnerabilities

critical Nessus Plugin ID 104631


The version of PHP running on the remote web server is affected by multiple vulnerabilities.


According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.32. It is, therefore, affected by multiple vulnerabilities.


Upgrade to PHP version 5.6.32 or later.

See Also

Plugin Details

Severity: Critical

ID: 104631

File Name: php_5_6_32.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 11/16/2017

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2016-1283


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 10/26/2017

Vulnerability Publication Date: 10/26/2016

Reference Information

CVE: CVE-2016-1283, CVE-2017-16642

BID: 79825, 101745