Adobe Photoshop CC 18.x < 18.1.2 Multiple Vulnerabilities (APSB17-34) (macOS)

High Nessus Plugin ID 104630

Synopsis

The remote host has an application installed that is affected by multiple vulnerabilities.

Description

The version of Adobe Photoshop CC installed on the remote macOS or Mac OS X host is 18.x prior to 18.1.2 (2017.1.2). It is, therefore, affected by multiple vulnerabilities. This includes two remote code execution vulnerabilities.

Solution

Upgrade to Adobe Photoshop CC version 18.1.2 (2017.1.2) or later.

See Also

https://helpx.adobe.com/security/products/photoshop/apsb17-34.html

Plugin Details

Severity: High

ID: 104630

File Name: macosx_adobe_photoshop_apsb17-34.nasl

Version: 1.3

Type: local

Agent: macosx

Published: 2017/11/16

Modified: 2018/05/17

Dependencies: 62220

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:photoshop_cc

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Photoshop

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/14

Vulnerability Publication Date: 2017/11/14

Reference Information

CVE: CVE-2017-11303, CVE-2017-11304

BID: 101829