RHEL 7 : rh-eclipse47-jackson-databind (RHSA-2017:3189)

High Nessus Plugin ID 104538

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An update for rh-eclipse47-jackson-databind is now available for Red Hat Developer Tools.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The jackson-databind package provides general data-binding functionality for Jackson, which works on top of Jackson core streaming API.

Security Fix(es) :

* A deserialization flaw was discovered in the jackson-databind which could allow an unauthenticated user to perform code execution by sending the maliciously crafted input to the readValue method of the ObjectMapper. This issue extends the previous flaw CVE-2017-7525 by blacklisting more classes that could be used maliciously.
(CVE-2017-15095)

Red Hat would like to thank Liao Xinxi (NSFOCUS) for reporting this issue.

Solution

Update the affected rh-eclipse47-jackson-databind and / or rh-eclipse47-jackson-databind-javadoc packages.

See Also

https://access.redhat.com/errata/RHSA-2017:3189

https://access.redhat.com/security/cve/cve-2017-15095

Plugin Details

Severity: High

ID: 104538

File Name: redhat-RHSA-2017-3189.nasl

Version: 3.10

Type: local

Agent: unix

Published: 2017/11/14

Updated: 2019/10/24

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:rh-eclipse47-jackson-databind, p-cpe:/a:redhat:enterprise_linux:rh-eclipse47-jackson-databind-javadoc, cpe:/o:redhat:enterprise_linux:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/13

Vulnerability Publication Date: 2018/02/06

Reference Information

CVE: CVE-2017-15095

RHSA: 2017:3189