GLSA-201711-06 : GNU Wget: Multiple vulnerabilities

High Nessus Plugin ID 104514

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201711-06 (GNU Wget: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Wget. Please review the referenced CVE identifiers for details.
Impact :

A remote attacker, by enticing a user to connect to a malicious server, could remotely execute arbitrary code or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Wget users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/wget-1.19.1-r2'

See Also

https://security.gentoo.org/glsa/201711-06

Plugin Details

Severity: High

ID: 104514

File Name: gentoo_GLSA-201711-06.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/11/13

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:wget, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/11/11

Reference Information

CVE: CVE-2017-13089, CVE-2017-13090

GLSA: 201711-06