GLSA-201711-01 : libxml2: Multiple vulnerabilities

High Nessus Plugin ID 104492

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201711-01 (libxml2: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in libxml2. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker, by enticing a user to process a specially crafted XML document, could remotely execute arbitrary code, conduct XML External Entity (XXE) attacks, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All libxml2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/libxml2-2.9.4-r3' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

See Also

https://security.gentoo.org/glsa/201711-01

Plugin Details

Severity: High

ID: 104492

File Name: gentoo_GLSA-201711-01.nasl

Version: 3.3

Type: local

Published: 2017/11/10

Modified: 2018/03/27

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libxml2, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/11/10

Reference Information

CVE: CVE-2016-9318, CVE-2017-0663, CVE-2017-5969, CVE-2017-7375, CVE-2017-9047, CVE-2017-9048, CVE-2017-9049, CVE-2017-9050

GLSA: 201711-01