Debian DSA-4028-1 : postgresql-9.6 - security update

Medium Nessus Plugin ID 104484

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been found in the PostgreSQL database system :

- CVE-2017-15098 Denial of service and potential memory disclosure in the json_populate_recordset() and jsonb_populate_recordset() functions

- CVE-2017-15099 Insufficient permissions checks in 'INSERT ... ON CONFLICT DO UPDATE' statements.

Solution

Upgrade the postgresql-9.6 packages.

For the stable distribution (stretch), these problems have been fixed in version 9.6.6-0+deb9u1.

See Also

https://security-tracker.debian.org/tracker/CVE-2017-15098

https://security-tracker.debian.org/tracker/CVE-2017-15099

https://packages.debian.org/source/stretch/postgresql-9.6

https://www.debian.org/security/2017/dsa-4028

Plugin Details

Severity: Medium

ID: 104484

File Name: debian_DSA-4028.nasl

Version: 3.8

Type: local

Agent: unix

Published: 2017/11/10

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:postgresql-9.6, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2017/11/09

Reference Information

CVE: CVE-2017-15098, CVE-2017-15099

DSA: 4028