Amazon Linux AMI : openvpn (ALAS-2017-920)

Medium Nessus Plugin ID 104394

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

OpenVPN versions before 2.3.3 and 2.4.x before 2.4.4 are vulnerable to a buffer overflow vulnerability when key-method 1 is used, possibly resulting in code execution. (CVE-2017-12166)

Solution

Run 'yum update openvpn' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2017-920.html

Plugin Details

Severity: Medium

ID: 104394

File Name: ala_ALAS-2017-920.nasl

Version: 3.6

Type: local

Agent: unix

Published: 2017/11/06

Modified: 2018/04/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:openvpn, p-cpe:/a:amazon:linux:openvpn-debuginfo, p-cpe:/a:amazon:linux:openvpn-devel, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2017/11/02

Reference Information

CVE: CVE-2017-12166

ALAS: 2017-920

IAVA: 2017-A-0285