WordPress < 4.8.3 Multiple Vulnerabilities

critical Nessus Plugin ID 104356


A PHP application running on the remote web server is affected a SQL injection vulnerability.


According to its self-reported version number, the WordPress application running on the remote web server is prior to 4.8.3.
It is, therefore, affected by a SQL Injection vulnerability and other vulnerabilities:

- WordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values.

- WordPress through 4.8.2, when domain-based flashmediaelement.swf sandboxing is not used, allows remote attackers to conduct cross-domain Flash injection (XSF) attacks by leveraging code contained within the wp-includes/js/mediaelement/flashmediaelement.swf file.


Upgrade to WordPress version 4.8.3 or later.

See Also




Plugin Details

Severity: Critical

ID: 104356

File Name: wordpress_4_8_3.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 11/2/2017

Updated: 3/29/2019

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2017-16510


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 10/31/2017

Vulnerability Publication Date: 10/31/2017

Reference Information

CVE: CVE-2012-6707, CVE-2016-9263, CVE-2017-14723, CVE-2017-16510

BID: 101638