Apache Solr 5.x < 5.5.5 / 6.x < 6.6.2 / 7.x < 7.1.0 Multiple Vulnerabilities

High Nessus Plugin ID 104353

Synopsis

The remote web server contains a Java application that is affected by multiple vulnerabilities.

Description

The version of Apache Solr running on the remote web server is affected by multiple vulnerabilities as referenced in the advisory.

Solution

Upgrade to Apache Solr version 5.5.5 / 6.6.2 / 7.1.0 or later.

See Also

http://lucene.apache.org/solr/news.html

https://seclists.org/oss-sec/2017/q4/105

http://www.nessus.org/u?552cc7b7

http://www.nessus.org/u?15df27f7

http://www.nessus.org/u?f91188b1

Plugin Details

Severity: High

ID: 104353

File Name: solr_7_1_0.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2017/11/02

Updated: 2019/11/12

Dependencies: 71843

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:solr

Required KB Items: installed_sw/Apache Solr

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2017/10/17

Vulnerability Publication Date: 2017/10/17

Reference Information

CVE: CVE-2017-12629

BID: 101261

IAVA: 2017-A-0319