EulerOS 2.0 SP1 : libexif (EulerOS-SA-2017-1276)

Medium Nessus Plugin ID 104329

Synopsis

The remote EulerOS host is missing a security update.

Description

According to the version of the libexif package installed, the EulerOS installation on the remote host is affected by the following vulnerability :

- libexif through 0.6.21 is vulnerable to out-of-bounds heap read vulnerability in exif_data_save_data_entry function in libexif/exif-data.c caused by improper length computation of the allocated data of an ExifMnote entry which can cause denial-of-service or possibly information disclosure.(CVE-2017-7544)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected libexif package.

See Also

http://www.nessus.org/u?3a25100c

Plugin Details

Severity: Medium

ID: 104329

File Name: EulerOS_SA-2017-1276.nasl

Version: 3.10

Type: local

Published: 2017/11/02

Updated: 2020/03/04

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:libexif, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Patch Publication Date: 2017/10/31

Reference Information

CVE: CVE-2017-7544