Debian DSA-4006-1 : mupdf - security update

Medium Nessus Plugin ID 104134

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been found in MuPDF, a PDF file viewer, which may result in denial of service or the execution of arbitrary code.

- CVE-2017-14685, CVE-2017-14686, and CVE-2017-14687 WangLin discovered that a crafted .xps file can crash MuPDF and potentially execute arbitrary code in several ways, since the application makes unchecked assumptions on the entry format.

- CVE-2017-15587 Terry Chia and Jeremy Heng discovered an integer overflow that can cause arbitrary code execution via a crafted .pdf file.

Solution

Upgrade the mupdf packages.

For the stable distribution (stretch), these problems have been fixed in version 1.9a+ds1-4+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=877379

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=879055

https://security-tracker.debian.org/tracker/CVE-2017-14685

https://security-tracker.debian.org/tracker/CVE-2017-14686

https://security-tracker.debian.org/tracker/CVE-2017-14687

https://security-tracker.debian.org/tracker/CVE-2017-15587

https://packages.debian.org/source/stretch/mupdf

https://www.debian.org/security/2017/dsa-4006

Plugin Details

Severity: Medium

ID: 104134

File Name: debian_DSA-4006.nasl

Version: 3.3

Type: local

Agent: unix

Published: 2017/10/25

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mupdf, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2017/10/24

Reference Information

CVE: CVE-2017-14685, CVE-2017-14686, CVE-2017-14687, CVE-2017-15587

DSA: 4006