Linksys E1500/E2500 Authenticated Command Execution

High Nessus Plugin ID 104129


The remote router is affected by an authenticated command execution vulnerability


The remote Linksys router is affected by an authenticated command execution vulnerability. An authenticated remote attacker can use this vulnerability to execute operating system commands as root.

This vulnerability has been used by the IoT Reaper botnet.


Upgrade to the latest firmware version.

See Also

Plugin Details

Severity: High

ID: 104129

File Name: linksys_auth_command_exec.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2017/10/25

Modified: 2018/03/12

Dependencies: 44391

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:U/RC:ND


Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

Required KB Items: installed_sw/Linksys

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2013/02/06

Exploitable With

Metasploit (Linksys E1500/E2500 apply.cgi Remote Command Injection)

Reference Information

BID: 57760