EulerOS 2.0 SP2 : libsndfile (EulerOS-SA-2017-1244)

High Nessus Plugin ID 103879

Synopsis

The remote EulerOS host is missing multiple security updates.

Description

According to the versions of the libsndfile package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities :

- An out of bounds read in the function d2alaw_array() in alaw.c of libsndfile 1.0.28 may lead to a remote DoS attack or information disclosure, related to mishandling of the NAN and INFINITY floating-point values.(CVE-2017-14245)

- An out of bounds read in the function d2ulaw_array() in ulaw.c of libsndfile 1.0.28 may lead to a remote DoS attack or information disclosure, related to mishandling of the NAN and INFINITY floating-point values.(CVE-2017-14246)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected libsndfile packages.

See Also

http://www.nessus.org/u?5099e17a

Plugin Details

Severity: High

ID: 103879

File Name: EulerOS_SA-2017-1244.nasl

Version: 3.10

Type: local

Published: 2017/10/18

Updated: 2018/11/14

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:libsndfile, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Patch Publication Date: 2017/10/18

Reference Information

CVE: CVE-2015-7805, CVE-2017-14245, CVE-2017-14246