GLSA-201710-15 : GnuTLS: Denial of Service

Medium Nessus Plugin ID 103850

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201710-15 (GnuTLS: Denial of Service)

A NULL pointer dereference while decoding a status response TLS extension with valid contents was discovered in GnuTLS.
Impact :

A remote attacker could possibly cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All GnuTLS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/gnutls-3.5.13' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

See Also

https://security.gentoo.org/glsa/201710-15

Plugin Details

Severity: Medium

ID: 103850

File Name: gentoo_GLSA-201710-15.nasl

Version: 3.2

Type: local

Published: 2017/10/16

Updated: 2018/06/07

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnutls, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/10/15

Reference Information

CVE: CVE-2017-7507

GLSA: 201710-15