GLSA-201710-01 : RubyGems: Multiple vulnerabilities

critical Nessus Plugin ID 103719

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201710-01 (RubyGems: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in RubyGems. Please review the referenced CVE identifiers for details.
Impact :

A remote attacker, by enticing a user to install a specially crafted gem, could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All RubyGems users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-ruby/rubygems-2.6.13'

See Also

https://security.gentoo.org/glsa/201710-01

Plugin Details

Severity: Critical

ID: 103719

File Name: gentoo_GLSA-201710-01.nasl

Version: 3.4

Type: local

Published: 10/9/2017

Updated: 1/11/2021

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:rubygems, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/8/2017

Reference Information

CVE: CVE-2017-0899, CVE-2017-0900, CVE-2017-0901, CVE-2017-0902

GLSA: 201710-01