Samba 4.4.x < 4.4.16 / 4.5.x < 4.5.14 / 4.6.x < 4.6.8 Multiple Vulnerabilities

Medium Nessus Plugin ID 103535


The remote Samba server is affected by multiple vulnerabilities.


The version of Samba running on the remote host is 4.4.x prior to 4.4.16, 4.5.x prior to 4.5.14, or 4.6.x prior to 4.6.8. It is, therefore, affected by the following vulnerabilities:

- Signing requirements are not properly enforced for SMB v1, v2, and v3. This could allow a man-in-the-middle attacker to interfere with client connections. (CVE-2017-12150)

- A flaw exists with the DFS redirect that causes encryption requirements to not be maintained. A man-in-the-middle attacker could read or alter the client connection. (CVE-2017-12151)

- A flaw exists with SMB v1 due to improper range check for client write requests. An authenticated attacker could potentially access sensitive server information. (CVE-2017-12163)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Samba version 4.4.16 / 4.5.14 / 4.6.8 or later.

See Also

Plugin Details

Severity: Medium

ID: 103535

File Name: samba_4_6_8.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 2017/09/28

Updated: 2018/07/27

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.4

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/09/20

Vulnerability Publication Date: 2017/09/20

Reference Information

CVE: CVE-2017-12150, CVE-2017-12151, CVE-2017-12163

BID: 100917, 100918, 100925