macOS : macOS Server < 5.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 103531


The remote host is missing a security update for macOS Server.


The version of macOS Server (formerly known as Mac OS X Server) installed on the remote host is prior to 5.4. It is, therefore, affected by the multiple Buffer Overflow DoS vulnerabilities in FreeRADIUS


Upgrade to macOS Server version 5.4 or later. Note that macOS Server version 5.4 is available only for macOS 10.12.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 103531

File Name: macos_server_5_4.nasl

Version: $Revision: 1.2 $

Type: local

Agent: macosx

Published: 2017/09/28

Modified: 2017/09/29

Dependencies: 50680

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:C


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/o:apple:os_x_server

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Server/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/09/25

Vulnerability Publication Date: 2017/09/25

Reference Information

CVE: CVE-2017-10978, CVE-2017-10979

BID: 99893, 99901

OSVDB: 161144, 161145

APPLE-SA: HT208102