McAfee Security Scan Plus < 3.11.599.3 LiveSafe Non-certificate-based Authentication HTTP Backend-response Handling MitM Registry Value Manipulation (TS102723)

High Nessus Plugin ID 103529


The security application installed on the remote Windows host is affected by a MitM command execution vulnerability.


The version of McAfee Security Scan Plus installed on the remote Windows host is prior to 3.11.599.3. It is, therefore, affected by a flaw in the non-certificate-based authentication mechanism that is triggered during the handling of HTTP backend-responses. This may allow a man-in-the-middle attacker to make changes to the Windows registry value associated with the McAfee update.


Upgrade to McAfee Security Scan Plus version 3.11.599.3 or later.

See Also

Plugin Details

Severity: High

ID: 103529

File Name: mcafee_ssp_3_11_599_3.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2017/09/28

Modified: 2017/09/29

Dependencies: 100131

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:mcafee:security_scan_plus

Required KB Items: installed_sw/McAfee Security Scan Plus

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/08/31

Vulnerability Publication Date: 2017/08/31

Reference Information

CVE: CVE-2017-3897, CVE-2017-3898

OSVDB: 162268

IAVB: 2017-B-0130