GLSA-201709-20 : Postfix: Privilege escalation

High Nessus Plugin ID 103448


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-20 (Postfix: Privilege escalation)

By default, Berkeley DB reads a DB_CONFIG configuration file from the current working directory. This is an undocumented behavior.
Impact :

A local attacker, by using a specially crafted DG_CONFIG file, could possibly escalate privileges to the root group.
Workaround :

There is no known workaround at this time.


All Postfix users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=mail-mta/postfix-3.1.6'

See Also

Plugin Details

Severity: High

ID: 103448

File Name: gentoo_GLSA-201709-20.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/09/25

Modified: 2017/10/02

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:postfix, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/24

Reference Information

GLSA: 201709-20