GLSA-201709-17 : CVS: Command injection

Medium Nessus Plugin ID 103445


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-17 (CVS: Command injection)

It was discovered that when CVS is configured to use SSH for remote repositories it allows remote attackers to execute arbitrary code through a repository URL with a specially crafted hostname.
Impact :

A remote attacker, by enticing a user to clone a specially crafted repository, could possibly execute arbitrary code with the privileges of the process.
Workaround :

There is no known workaround at this time.


All CVS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-vcs/cvs-1.12.12-r12'

See Also

Plugin Details

Severity: Medium

ID: 103445

File Name: gentoo_GLSA-201709-17.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/09/25

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cvs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/24

Reference Information

CVE: CVE-2017-12836

GLSA: 201709-17