VMware Workstation 12.x < 12.5.7 Multiple Vulnerabilities (VMSA-2017-0015) (Linux)

Medium Nessus Plugin ID 103379


A virtualization application installed on the remote Linux host is affected by multiple vulnerabilities.


The version of VMware Workstation installed on the remote Linux host is 12.x prior to 12.5.7. It is, therefore, affected by the following vulnerabilities:

- A remote code execution vulnerability exists in VMware workstation within the SVGA device. An attacker with user access can exploit this to execute arbitrary code. (CVE-2017-4924)

- A denial of service vulnerability exists in VMware workstation due to a NULL pointer deference when handling guest RPC requests. An attacker with guest access can exploit this to crash their VMs.
NOTE: This vulnerability only affects VMware Workstation 12.5.2 and below. (CVE-2017-4925)


Upgrade to VMware Workstation version 12.5.7 or later.

See Also


Plugin Details

Severity: Medium

ID: 103379

File Name: vmware_workstation_linux_vmsa_2017_0015.nasl

Version: $Revision: 1.4 $

Type: local

Family: General

Published: 2017/09/21

Modified: 2017/11/30

Dependencies: 71053

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 8.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: Host/VMware Workstation/Version, Settings/ParanoidReport

Excluded KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/09/14

Vulnerability Publication Date: 2017/03/09

Reference Information

CVE: CVE-2017-4924, CVE-2017-4925

BID: 100842, 100843

OSVDB: 165468, 165469

VMSA: 2017-0015