VMware vCenter Server 6.5.x < 6.5u1 H5 Client Stored XSS (VMSA-2017-0015)

Medium Nessus Plugin ID 103377


A virtualization management application installed on the remote host is affected by a stored cross-site scripting vulnerability.


The version of VMware vCenter Server installed on the remote host is 6.5.x prior to 6.5u1. It is, therefore, affected by a user-input validation error related to the 'H5 Client' that allows stored cross-site scripting (XSS) attacks.


Upgrade to VMware vCenter Server version 6.5.0u1 (6.5.0 build-5973321) or later. Alternatively, apply the vendor-supplied workaround.

See Also



Plugin Details

Severity: Medium

ID: 103377

File Name: vmware_vcenter_vmsa-2017-0015.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Misc.

Published: 2017/09/21

Modified: 2017/09/22

Dependencies: 63061, 11936, 22964

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/07/27

Vulnerability Publication Date: 2017/09/15

Reference Information

CVE: CVE-2017-4926

BID: 100844

OSVDB: 165470

VMSA: 2017-0015