VMware Fusion 8.x < 8.5.8 SVGA Code Execution Vulnerability (VMSA-2017-0015) (macOS)

High Nessus Plugin ID 103374


A virtualization application installed on the remote macOS or Mac OS X host is affected by a code execution vulnerability.


The version of VMware Fusion installed on the remote macOS or Mac OS X host is 8.x prior to 8.5.8. It is, therefore, affected by an out-of- bounds write error related to SVGA devices that allows a guest virtual machine to execute code on the host.


Upgrade to VMware Fusion version 8.5.8 or later.

See Also


Plugin Details

Severity: High

ID: 103374

File Name: macosx_fusion_vmsa_2017_0015__8_5_8.nasl

Version: $Revision: 1.3 $

Type: local

Agent: macosx

Published: 2017/09/21

Modified: 2017/11/30

Dependencies: 50828

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 9.3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:vmware:fusion

Required KB Items: Host/local_checks_enabled, installed_sw/VMware Fusion, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/09/15

Vulnerability Publication Date: 2017/09/15

Reference Information

CVE: CVE-2017-4924

BID: 100843

OSVDB: 165469

VMSA: 2017-0015