Apache Tomcat 7.0.x < 7.0.81 Multiple Vulnerabilities
High Nessus Plugin ID 103329
SynopsisThe remote Apache Tomcat server is affected by multiple vulnerabilities.
DescriptionThe version of Apache Tomcat installed on the remote host is 7.0.x prior to 7.0.81. It is, therefore, affected by multiple vulnerabilities :
- An unspecified vulnerability when running on Windows with HTTP PUTs enabled (e.g. via setting the readonly initialization parameter of the Default to false) makes it possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server. (CVE-2017-12615, CVE-2017-12617)
- When using a VirtualDirContext it was possible to bypass security constraints and/or view the source code of JSPs for resources served by the VirtualDirContext using a specially crafted request. (CVE-2017-12616)
Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Apache Tomcat version 7.0.81 or later.
Note that the remote code execution issue was fixed in Apache Tomcat 7.0.80 but the release vote for the 7.0.81 release candidate did not pass. Therefore, although users must download 7.0.81 to obtain a version that includes the fix for this issue, version 7.0.80 is not included in the list of affected versions.