Apache Tomcat 7.0.x < 7.0.81 Multiple Vulnerabilities

High Nessus Plugin ID 103329


The remote Apache Tomcat server is affected by multiple vulnerabilities.


The version of Apache Tomcat installed on the remote host is 7.0.x prior to 7.0.81. It is, therefore, affected by multiple vulnerabilities :

- An unspecified vulnerability when running on Windows with HTTP PUTs enabled (e.g. via setting the readonly initialization parameter of the Default to false) makes it possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server. (CVE-2017-12615, CVE-2017-12617)

- When using a VirtualDirContext it was possible to bypass security constraints and/or view the source code of JSPs for resources served by the VirtualDirContext using a specially crafted request. (CVE-2017-12616)

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 7.0.81 or later.

Note that the remote code execution issue was fixed in Apache Tomcat 7.0.80 but the release vote for the 7.0.81 release candidate did not pass. Therefore, although users must download 7.0.81 to obtain a version that includes the fix for this issue, version 7.0.80 is not included in the list of affected versions.

See Also


Plugin Details

Severity: High

ID: 103329

File Name: tomcat_7_0_81.nasl

Version: $Revision: 1.14 $

Type: remote

Family: Web Servers

Published: 2017/09/19

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/08/16

Vulnerability Publication Date: 2017/08/16

Exploitable With


Reference Information

CVE: CVE-2017-12615, CVE-2017-12616

BID: 100897, 100901

OSVDB: 114313, 114314, 165695, 165696