GLSA-201709-11 : GIMPS: Root privilege escalation

High Nessus Plugin ID 103279


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-11 (GIMPS: Root privilege escalation)

It was discovered that Gentoo’s default GIMPS installation suffered from a privilege escalation vulnerability in the init script. This script calls an unsafe “chown -R” command in checkconfig() function.
Impact :

A local attacker who does not belong to the root group, but has the ability to modify the /var/lib/gimps directory can escalate privileges to the root group.
Workaround :

There is no known workaround at this time.


All GIMPS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sci-mathematics/gimps-28.10-r1'

See Also

Plugin Details

Severity: High

ID: 103279

File Name: gentoo_GLSA-201709-11.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/09/18

Modified: 2017/09/18

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gimps, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/17

Reference Information

GLSA: 201709-11