GLSA-201709-08 : GDK-PixBuf: Multiple vulnerabilities

Medium Nessus Plugin ID 103276


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-08 (GDK-PixBuf: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in GDK-PixBuf. Please review the referenced CVE identifiers for details.
Impact :

A remote attacker, by sending a specially crafted TIFF, JPEG, or URL, could execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All GDK-PixBuf users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/gdk-pixbuf-2.36.9' Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

See Also

Plugin Details

Severity: Medium

ID: 103276

File Name: gentoo_GLSA-201709-08.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/09/18

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gdk-pixbuf, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/17

Reference Information

CVE: CVE-2017-6311, CVE-2017-6312, CVE-2017-6313, CVE-2017-6314

GLSA: 201709-08