GLSA-201709-04 : mod_gnutls: Certificate validation error

Medium Nessus Plugin ID 103272


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-04 (mod_gnutls: Certificate validation error)

It was discovered that the authentication hook in mod_gnutls does not validate client’s certificates even when option “GnuTLSClientVerify” is set to “require”.
Impact :

A remote attacker could present a crafted certificate and spoof clients data.
Workaround :

There is no known workaround at this time.


All mod_gnutls users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apache/mod_gnutls-0.7.3'

See Also

Plugin Details

Severity: Medium

ID: 103272

File Name: gentoo_GLSA-201709-04.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/09/18

Modified: 2017/10/02

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mod_gnutls, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/17

Reference Information

CVE: CVE-2015-2091

GLSA: 201709-04