GLSA-201709-02 : Binutils: Multiple vulnerabilities

High Nessus Plugin ID 103270


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-02 (Binutils: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Binutils. Please review References for additional information.
Impact :

A remote attacker, by enticing a user to compile/execute a specially crafted ELF file, PE File, or binary file, could possibly cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Binutils users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-devel/binutils-2.28.1'

See Also

Plugin Details

Severity: High

ID: 103270

File Name: gentoo_GLSA-201709-02.nasl

Version: $Revision: 3.3 $

Type: local

Published: 2017/09/18

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:binutils, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/17

Reference Information

CVE: CVE-2017-6965, CVE-2017-6966, CVE-2017-6969, CVE-2017-7614, CVE-2017-8392, CVE-2017-8393, CVE-2017-8394, CVE-2017-8395, CVE-2017-8396, CVE-2017-8397, CVE-2017-8398, CVE-2017-8421, CVE-2017-9038, CVE-2017-9039, CVE-2017-9040, CVE-2017-9041, CVE-2017-9042, CVE-2017-9742, CVE-2017-9954

GLSA: 201709-02