Asterisk 11.x < 11.25.2 / 11.6 < 11.6-cert17 / 13.x < 13.17.1 / 14.x < 14.6.1 / 13.13 < 13.13-cert5 Multiple Vulnerabilities (AST-2017-005 - AST-2017-007)
High Nessus Plugin ID 102958
SynopsisA telephony application running on the remote host is affected by multiple vulnerabilities.
DescriptionAccording to its SIP banner, the version of Asterisk running on the remote host is 11.x prior to 11.25.2, 13.x prior to 13.17.1, 14.x prior to 14.6.1, 11.6 prior to 11.6-cert17, or 13.13 prior to 13.13-cert5. It is therefore, affected by multiple vulnerabilities as described in AST-2017-005, AST-2017-006, and AST-2017-007.
Note for AST-2017-005, only 11.4.0 is affected in the 11.x branch.
Also note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Asterisk version 11.25.2 / 13.17.1 / 14.6.1 / 11.6-cert17 / 13.13-cert5 or later.