Asterisk 11.x < 11.25.2 / 11.6 < 11.6-cert17 / 13.x < 13.17.1 / 14.x < 14.6.1 / 13.13 < 13.13-cert5 Multiple Vulnerabilities (AST-2017-005 - AST-2017-007)

High Nessus Plugin ID 102958


A telephony application running on the remote host is affected by multiple vulnerabilities.


According to its SIP banner, the version of Asterisk running on the remote host is 11.x prior to 11.25.2, 13.x prior to 13.17.1, 14.x prior to 14.6.1, 11.6 prior to 11.6-cert17, or 13.13 prior to 13.13-cert5. It is therefore, affected by multiple vulnerabilities as described in AST-2017-005, AST-2017-006, and AST-2017-007.

Note for AST-2017-005, only 11.4.0 is affected in the 11.x branch.

Also note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 11.25.2 / 13.17.1 / 14.6.1 / 11.6-cert17 / 13.13-cert5 or later.

See Also

Plugin Details

Severity: High

ID: 102958

File Name: asterisk_ast_2017_005-007.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Misc.

Published: 2017/09/05

Modified: 2017/10/19

Dependencies: 63202

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 6.3

Temporal Score: 5.8

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2017-14098, CVE-2017-14099, CVE-2017-14100

OSVDB: 164472, 164473, 164474