GLSA-201709-01 : MCollective: Remote Code Execution

High Nessus Plugin ID 102942


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201709-01 (MCollective: Remote Code Execution)

A vulnerability was discovered in MCollective which allowed for deserialized YAML from agents without calling safe_load. This allows the potential for arbitrary code execution on the server.
Impact :

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All MCollective users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-admin/mcollective-2.11.0'

See Also

Plugin Details

Severity: High

ID: 102942

File Name: gentoo_GLSA-201709-01.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2017/09/05

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mcollective, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/09/04

Reference Information

CVE: CVE-2017-2292

GLSA: 201709-01