Debian DSA-3964-1 : asterisk - security update

High Nessus Plugin ID 102931

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been discovered in Asterisk, an open source PBX and telephony toolkit, which may result in disclosure of RTP connections or the execution of arbitrary shell commands.

For additional information please refer to the upstream advisories:
http://downloads.asterisk.org/pub/security/AST-2017-005.html, http://downloads.asterisk.org/pub/security/AST-2017-006.html

Solution

Upgrade the asterisk packages.

For the oldstable distribution (jessie), these problems have been fixed in version 1:11.13.1~dfsg-2+deb8u3.

For the stable distribution (stretch), these problems have been fixed in version 1:13.14.1~dfsg-2+deb9u1.

See Also

http://downloads.asterisk.org/pub/security/AST-2017-005.html

http://downloads.asterisk.org/pub/security/AST-2017-006.html

https://packages.debian.org/source/jessie/asterisk

https://packages.debian.org/source/stretch/asterisk

https://www.debian.org/security/2017/dsa-3964

Plugin Details

Severity: High

ID: 102931

File Name: debian_DSA-3964.nasl

Version: 3.7

Type: local

Agent: unix

Published: 2017/09/05

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:asterisk, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2017/09/04

Reference Information

CVE: CVE-2017-14099, CVE-2017-14100

DSA: 3964