Scientific Linux Security Update : poppler on SL7.x x86_64 (20170830)

high Nessus Plugin ID 102853

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Security Fix(es) :

- A stack-based buffer overflow was found in the poppler library. An attacker could create a malicious PDF file that would cause applications that use poppler (such as Evince) to crash, or potentially execute arbitrary code when opened. (CVE-2017-9775)

- An integer overflow leading to heap-based buffer overflow was found in the poppler library. An attacker could create a malicious PDF file that would cause applications that use poppler (such as Evince) to crash, or potentially execute arbitrary code when opened.
(CVE-2017-9776)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?e83d3091

Plugin Details

Severity: High

ID: 102853

File Name: sl_20170830_poppler_on_SL7_x.nasl

Version: 3.8

Type: local

Agent: unix

Published: 8/31/2017

Updated: 1/14/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: High

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:fermilab:scientific_linux:poppler, p-cpe:/a:fermilab:scientific_linux:poppler-cpp, p-cpe:/a:fermilab:scientific_linux:poppler-cpp-devel, p-cpe:/a:fermilab:scientific_linux:poppler-debuginfo, p-cpe:/a:fermilab:scientific_linux:poppler-demos, p-cpe:/a:fermilab:scientific_linux:poppler-devel, p-cpe:/a:fermilab:scientific_linux:poppler-glib, p-cpe:/a:fermilab:scientific_linux:poppler-glib-devel, p-cpe:/a:fermilab:scientific_linux:poppler-qt, p-cpe:/a:fermilab:scientific_linux:poppler-qt-devel, p-cpe:/a:fermilab:scientific_linux:poppler-utils, x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 8/30/2017

Vulnerability Publication Date: 6/22/2017

Reference Information

CVE: CVE-2017-9775, CVE-2017-9776