Juniper Junos Sockets Library Buffer Overflow Privilege Escalation (JSA10792)

High Nessus Plugin ID 102705


The remote device is missing a vendor-supplied security patch.


According to its self-reported version number, the remote Juniper Junos device is affected by a privilege escalation vulnerability in the sockets library due to a buffer overflow condition. A local attacker can exploit this to cause a denial of service (kernel panic) or the execution of arbitrary code with elevated privileges.


Upgrade to the relevant Junos software release referenced in Juniper security advisory JSA10792.

See Also

Plugin Details

Severity: High

ID: 102705

File Name: juniper_jsa10792.nasl

Version: $Revision: 1.2 $

Type: combined

Published: 2017/08/23

Modified: 2017/08/24

Dependencies: 55932

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:juniper:junos

Required KB Items: Host/Juniper/JUNOS/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/10/12

Vulnerability Publication Date: 2016/10/12

Reference Information

CVE: CVE-2017-2344

BID: 99556

OSVDB: 160907

JSA: JSA10792