Apache Tomcat 8.5.x < 8.5.16 Multiple Vulnerabilities

Medium Nessus Plugin ID 102589


The remote Apache Tomcat server is affected by multiple vulnerabilities.


The version of Apache Tomcat installed on the remote host is 8.5.x prior to 8.5.16. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the CORS filter because the HTTP Vary header was not properly added. This allows a remote attacker to conduct client-side and server-side cache poisoning attacks.

- A flaw exists in the HTTP/2 implementation that bypasses a number of security checks that prevented directory traversal attacks. A remote attacker can exploit this to bypass security constraints.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 8.5.16 or later.

See Also


Plugin Details

Severity: Medium

ID: 102589

File Name: tomcat_8_5_16.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Web Servers

Published: 2017/08/18

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/08/10

Vulnerability Publication Date: 2017/05/16

Reference Information

CVE: CVE-2017-7674, CVE-2017-7675

BID: 100256, 100280

OSVDB: 163109, 163110