Xen Hypervisor Multiple Vulnerabilities (XSA-226 - XSA-230)

High Nessus Plugin ID 102585

Synopsis

The remote Xen hypervisor installation is missing a security update.

Description

According to its self-reported version number, the Xen hypervisor installed on the remote host is affected by multiple vulnerabilities.

Note that Nessus has checked the changeset versions based on the xen.git change log. Nessus did not check guest hardware configurations or if patches were applied manually to the source code before a recompile and reinstall.

Solution

Apply the appropriate patch according to the vendor advisory.

See Also

http://xenbits.xen.org/xsa/advisory-226.html

http://xenbits.xen.org/xsa/advisory-227.html

http://xenbits.xen.org/xsa/advisory-228.html

http://xenbits.xen.org/xsa/advisory-229.html

http://xenbits.xen.org/xsa/advisory-230.html

https://xenbits.xen.org/gitweb/?p=xen.git;a=summary

Plugin Details

Severity: High

ID: 102585

File Name: xen_server_XSA-230.nasl

Version: 1.5

Type: local

Family: Misc.

Published: 2017/08/18

Updated: 2018/08/08

Dependencies: 78089

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:xen:xen

Required KB Items: installed_sw/Xen Hypervisor, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/08/15

Vulnerability Publication Date: 2017/08/15

Reference Information

CVE: CVE-2017-12134, CVE-2017-12135, CVE-2017-12136, CVE-2017-12137, CVE-2017-12855

BID: 100341, 100342, 100343, 100344, 100346

IAVB: 2017-B-0108