Debian DSA-3944-1 : mariadb-10.0 - security update

high Nessus Plugin ID 102529

Synopsis

The remote Debian host is missing a security-related update.

Description

Several issues have been discovered in the MariaDB database server.
The vulnerabilities are addressed by upgrading MariaDB to the new upstream version 10.0.32. Please see the MariaDB 10.0 Release Notes for further details :

- https://mariadb.com/kb/en/mariadb/mariadb-10031-release- notes/
- https://mariadb.com/kb/en/mariadb/mariadb-10032-release- notes/

Solution

Upgrade the mariadb-10.0 packages.

For the oldstable distribution (jessie), these problems have been fixed in version 10.0.32-0+deb8u1.

See Also

https://mariadb.com/kb/en/library/mariadb-10031-release-notes/

https://mariadb.com/kb/en/library/mariadb-10032-release-notes/

https://packages.debian.org/source/jessie/mariadb-10.0

https://www.debian.org/security/2017/dsa-3944

Plugin Details

Severity: High

ID: 102529

File Name: debian_DSA-3944.nasl

Version: 3.6

Type: local

Agent: unix

Published: 8/17/2017

Updated: 1/4/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: High

Base Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mariadb-10.0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 8/17/2017

Reference Information

CVE: CVE-2017-3308, CVE-2017-3309, CVE-2017-3453, CVE-2017-3456, CVE-2017-3464, CVE-2017-3636, CVE-2017-3641, CVE-2017-3653

DSA: 3944