Zabbix 3.2.x < 3.2.7 Multiple Vulnerabilities

critical Nessus Plugin ID 102495


A web application running on the remote host is affected by multiple vulnerabilities.


According to its self-reported version number, the instance of Zabbix running on the remote host is 3.2.x prior to 3.2.7. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists that allows a reflected cross-site scripting (XSS) attack. This flaw exists because the actionconf.php script does not validate input to the 'tab' parameter before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

- An unspecified flaw exists that may allow a remote attacker to execute arbitrary commands on the server.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Zabbix version 3.2.7 or later.

See Also

Plugin Details

Severity: Critical

ID: 102495

File Name: zabbix_frontend_3_2_7.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 8/15/2017

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:zabbix:zabbix

Required KB Items: installed_sw/zabbix

Patch Publication Date: 7/18/2017

Vulnerability Publication Date: 7/18/2017