Debian DSA-3938-1 : libgd2 - security update

Medium Nessus Plugin ID 102445

Synopsis

The remote Debian host is missing a security-related update.

Description

Matviy Kotoniy reported that the gdImageCreateFromGifCtx() function used to load images from GIF format files in libgd2, a library for programmatic graphics creation and manipulation, does not zero stack allocated color map buffers before their use, which may result in information disclosure if a specially crafted file is processed.

Solution

Upgrade the libgd2 packages.

For the oldstable distribution (jessie), this problem has been fixed in version 2.1.0-5+deb8u10.

For the stable distribution (stretch), this problem has been fixed in version 2.2.4-2+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869263

https://packages.debian.org/source/jessie/libgd2

https://packages.debian.org/source/stretch/libgd2

https://www.debian.org/security/2017/dsa-3938

Plugin Details

Severity: Medium

ID: 102445

File Name: debian_DSA-3938.nasl

Version: 3.8

Type: local

Agent: unix

Published: 2017/08/14

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libgd2, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/08/12

Reference Information

CVE: CVE-2017-7890

DSA: 3938