Oracle Linux 7 : gtk-vnc (ELSA-2017-2258)

High Nessus Plugin ID 102301


The remote Oracle Linux host is missing one or more security updates.


From Red Hat Security Advisory 2017:2258 :

An update for gtk-vnc is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

The gtk-vnc packages provide a VNC viewer widget for GTK. The gtk-vnc widget is built by using co-routines, which allows the widget to be completely asynchronous while remaining single-threaded.

The following packages have been upgraded to a later upstream version:
gtk-vnc (0.7.0). (BZ#1416783)

Security Fix(es) :

* It was found that gtk-vnc lacked proper bounds checking while processing messages using RRE, hextile, or copyrect encodings. A remote malicious VNC server could use this flaw to crash VNC viewers which are based on the gtk-vnc library. (CVE-2017-5884)

* An integer overflow flaw was found in gtk-vnc. A remote malicious VNC server could use this flaw to crash VNC viewers which are based on the gtk-vnc library. (CVE-2017-5885)

Additional Changes :

For detailed information on changes in this release, see the Red Hat Enterprise Linux 7.4 Release Notes linked from the References section.


Update the affected gtk-vnc packages.

See Also

Plugin Details

Severity: High

ID: 102301

File Name: oraclelinux_ELSA-2017-2258.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/08/09

Modified: 2017/08/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:U/RC:ND


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:gtk-vnc, p-cpe:/a:oracle:linux:gtk-vnc-devel, p-cpe:/a:oracle:linux:gtk-vnc-python, p-cpe:/a:oracle:linux:gtk-vnc2, p-cpe:/a:oracle:linux:gtk-vnc2-devel, p-cpe:/a:oracle:linux:gvnc, p-cpe:/a:oracle:linux:gvnc-devel, p-cpe:/a:oracle:linux:gvnc-tools, p-cpe:/a:oracle:linux:gvncpulse, p-cpe:/a:oracle:linux:gvncpulse-devel, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/08/08

Reference Information

CVE: CVE-2017-5884, CVE-2017-5885

OSVDB: 151479, 151480

RHSA: 2017:2258