Oracle Linux 7 : python (ELSA-2017-1868)

Medium Nessus Plugin ID 102286


The remote Oracle Linux host is missing one or more security updates.


From Red Hat Security Advisory 2017:1868 :

An update for python is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Python is an interpreted, interactive, object-oriented programming language, which includes modules, classes, exceptions, very high level dynamic data types and dynamic typing. Python supports interfaces to many system calls and libraries, as well as to various windowing systems.

Security Fix(es) :

* The Python standard library HTTP client modules (such as httplib or urllib) did not perform verification of TLS/SSL certificates when connecting to HTTPS servers. A man-in-the-middle attacker could use this flaw to hijack connections and eavesdrop or modify transferred data. (CVE-2014-9365)

Note: The Python standard library was updated to enable certificate verification by default. Refer to the Knowledgebase article 2039753 linked to in the References section for further details about this change. (BZ#1219110)

Additional Changes :

For detailed information on changes in this release, see the Red Hat Enterprise Linux 7.4 Release Notes linked from the References section.


Update the affected python packages.

See Also

Plugin Details

Severity: Medium

ID: 102286

File Name: oraclelinux_ELSA-2017-1868.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/08/09

Modified: 2017/08/09

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:python, p-cpe:/a:oracle:linux:python-debug, p-cpe:/a:oracle:linux:python-devel, p-cpe:/a:oracle:linux:python-libs, p-cpe:/a:oracle:linux:python-test, p-cpe:/a:oracle:linux:python-tools, p-cpe:/a:oracle:linux:tkinter, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/08/08

Reference Information

CVE: CVE-2014-9365

OSVDB: 115871

RHSA: 2017:1868