Tenable Nessus Agent 6.x < 6.11 MITM Vulnerability During Linking (TNS-2017-11)

high Nessus Plugin ID 102274
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of Nessus Agent installed on the remote host is affected by a MITM vulnerability.

Description

The version of Nessus Agent installed on the remote Windows host is 6.x prior to 6.11. It is, therefore, affected by a MITM vulnerability that can be exploited during the agent linking process. This is due to the fact that during an initial connection to Tenable.io or Nessus Manager when linking the agent, it does not verify the server certificate.

Solution

Upgrade to Tenable Nessus Agent version 6.11 or later.

See Also

https://www.tenable.com/security/tns-2017-11

Plugin Details

Severity: High

ID: 102274

File Name: tenable_nessus_agent_tns_2017_11.nasl

Version: 1.9

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 8/8/2017

Updated: 11/12/2019

Dependencies: tenable_nessus_agent_installed_win.nbin, nessus_agent_installed_macos.nbin, nessus_agent_installed_linux.nbin

Risk Information

CVSS Score Source: CVE-2017-11506

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.4

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/Tenable Nessus Agent

Exploit Ease: No known exploits are available

Patch Publication Date: 8/7/2017

Vulnerability Publication Date: 8/8/2017

Reference Information

CVE: CVE-2017-11506