ProFTPD NLST Command Argument Handling Remote Overflow

Critical Nessus Plugin ID 10191


The remote FTP server is affected by a buffer overflow vulnerability.


It was possible to crash the remote FTP server by issuing a specially crafted command, such as 'NLST aaaXXXX%u%[...]%u%u%u%%u%653300u%n' where 'XXXX' is replaced with four characters - ASCII values 0xDC, 0x4F, 0x07 and 0x08. This issue is known to affect ProFTPD version 1.2.0pre6, although other FTP servers may be affected as well.

It is likely that a remote attacker can leverage this issue to execute arbitrary code on the remote host, subject to the privileges under which the service runs.


If running ProFTPD, upgrade to version 1.2.0pre7 or later; otherwise, contact the vendor to see if an update exists.

See Also

Plugin Details

Severity: Critical

ID: 10191

File Name: proftpd_pre6_exploit.nasl

Version: $Revision: 1.48 $

Type: remote

Family: FTP

Published: 1999/09/21

Modified: 2016/11/02

Dependencies: 10318, 10092

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:proftpd:proftpd

Required KB Items: ftp/login, Settings/ParanoidReport

Excluded KB Items: ftp/ncftpd, ftp/msftpd

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-1999-0911

BID: 612

OSVDB: 144, 51720