Debian DSA-3913-1 : apache2 - security update

critical Nessus Plugin ID 101793

Synopsis

The remote Debian host is missing a security-related update.

Description

Robert Swiecki reported that mod_auth_digest does not properly initialize or reset the value placeholder in [Proxy-]Authorization headers of type 'Digest' between successive key=value assignments, leading to information disclosure or denial of service.

Solution

Upgrade the apache2 packages.

For the oldstable distribution (jessie), this problem has been fixed in version 2.4.10-10+deb8u10.

For the stable distribution (stretch), this problem has been fixed in version 2.4.25-3+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=868467

https://packages.debian.org/source/jessie/apache2

https://packages.debian.org/source/stretch/apache2

https://www.debian.org/security/2017/dsa-3913

Plugin Details

Severity: Critical

ID: 101793

File Name: debian_DSA-3913.nasl

Version: 3.12

Type: local

Agent: unix

Published: 7/19/2017

Updated: 1/4/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:apache2, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 7/18/2017

Reference Information

CVE: CVE-2017-9788

DSA: 3913