IBM Integration Bus 8.x < / 9.x < / 10.x < Multiple Vulnerabilities

Medium Nessus Plugin ID 101521


An enterprise service bus application installed on the remote host is affected by multiple vulnerabilities.


The version of IBM Integration Bus (formerly known as IBM WebSphere Message Broker) installed on the remote host is 8.x prior to, 9.x prior to, or 10.x prior to It is, therefore, affected by multiple vulnerabilities :

- A denial of service vulnerability exists due to the use of an unquoted search path that allows a local attacker with specialized access to prevent the message broker from starting. (CVE-2017-1144)

- An information disclosure vulnerability exists in the service trace component due to logging passwords in plaintext. A local attacker can exploit this to disclose web user passwords. (CVE-2017-1207)


Upgrade to IBM Integration Bus version / / or later.

See Also

Plugin Details

Severity: Medium

ID: 101521

File Name: ibm_integration_bus_swg22005382.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2017/07/13

Modified: 2017/10/12

Dependencies: 97579

Risk Information

Risk Factor: Medium


Base Score: 4.9

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 4.4

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:ibm:websphere_message_broker, cpe:/a:ibm:integration_bus

Required KB Items: installed_sw/IBM Integration Bus

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/06/30

Vulnerability Publication Date: 2017/06/30

Reference Information

CVE: CVE-2017-1144, CVE-2017-1207

BID: 99365, 99368

OSVDB: 160221, 160222