Virtuozzo 7 : ipa-admintools / ipa-client / ipa-client-common / etc (VZLSA-2017-0388)

Medium Nessus Plugin ID 101432


The remote Virtuozzo host is missing a security update.


An update for ipa is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Red Hat Identity Management (IdM) is a centralized authentication, identity management, and authorization solution for both traditional and cloud-based enterprise environments.

Security Fix(es) :

* It was found that IdM's ca-del, ca-disable, and ca-enable commands did not properly check the user's permissions while modifying CAs in Dogtag. An authenticated, unauthorized attacker could use this flaw to delete, disable, or enable CAs causing various denial of service problems with certificate issuance, OCSP signing, and deletion of secret keys. (CVE-2017-2590)

This issue was discovered by Fraser Tweedale (Red Hat).

Bug Fix(es) :

* Previously, during an Identity Management (IdM) replica installation that runs on domain level '1' or higher, Directory Server was not configured to use TLS encryption. As a consequence, installing a certificate authority (CA) on that replica failed. Directory Server is now configured to use TLS encryption during the replica installation and as a result, the CA installation works as expected. (BZ#1410760)

* Previously, the Identity Management (IdM) public key infrastructure (PKI) component was configured to listen on the '::1' IPv6 localhost address. In environments have the the IPv6 protocol disabled, the replica installer was unable to retrieve the Directory Server certificate, and the installation failed. The default listening address of the PKI connector has been updated from the IP address to 'localhost'. As a result, the PKI connector now listens on the correct addresses in IPv4 and IPv6 environments. (BZ#1416481)

* Previously, when installing a certificate authority (CA) on a replica, Identity Management (IdM) was unable to provide third-party CA certificates to the Certificate System CA installer. As a consequence, the installer was unable to connect to the remote master if the remote master used a third-party server certificate, and the installation failed. This updates applies a patch and as a result, installing a CA replica works as expected in the described situation.

* When installing a replica, the web server service entry is created on the Identity Management (IdM) master and replicated to all IdM servers. Previously, when installing a replica without a certificate authority (CA), in certain situations the service entry was not replicated to the new replica on time, and the installation failed.
The replica installer has been updated and now waits until the web server service entry is replicated. As a result, the replica installation no longer fails in the described situation. (BZ#1416488)

Note that Tenable Network Security has attempted to extract the preceding description block directly from the corresponding Red Hat security advisory. Virtuozzo provides no description for VZLSA advisories. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected ipa-admintools / ipa-client / ipa-client-common / etc package.

See Also

Plugin Details

Severity: Medium

ID: 101432

File Name: Virtuozzo_VZLSA-2017-0388.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2017/07/13

Modified: 2017/07/18

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

CPE: p-cpe:/a:virtuozzo:virtuozzo:ipa-admintools, p-cpe:/a:virtuozzo:virtuozzo:ipa-client, p-cpe:/a:virtuozzo:virtuozzo:ipa-client-common, p-cpe:/a:virtuozzo:virtuozzo:ipa-common, p-cpe:/a:virtuozzo:virtuozzo:ipa-python-compat, p-cpe:/a:virtuozzo:virtuozzo:ipa-server, p-cpe:/a:virtuozzo:virtuozzo:ipa-server-common, p-cpe:/a:virtuozzo:virtuozzo:ipa-server-dns, p-cpe:/a:virtuozzo:virtuozzo:ipa-server-trust-ad, p-cpe:/a:virtuozzo:virtuozzo:python2-ipaclient, p-cpe:/a:virtuozzo:virtuozzo:python2-ipalib, p-cpe:/a:virtuozzo:virtuozzo:python2-ipaserver, cpe:/o:virtuozzo:virtuozzo:7

Required KB Items: Host/local_checks_enabled, Host/Virtuozzo/release, Host/Virtuozzo/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/03/03

Reference Information

CVE: CVE-2017-2590

OSVDB: 152644