Veritas Backup Exec Remote Agent 14.1.x < 14.1.1786.1126 / 14.2.x < 14.2.1180.3160 / 16.0.x < 16.0.1142.1327 Use-after-free RCE (VTS17-006)

Critical Nessus Plugin ID 101294


A remote data protection agent installed on the remote host is affected by a remote code execution vulnerability.


The version of Vertias Backup Exec Remote Agent installed on the remote Windows host is 14.1.x prior to 14.1.1786.1126, 14.2.x prior to 14.2.1180.3160, or 16.0.x prior to 16.0.1142.1327. It is, therefore, affected by a remote code execution vulnerability due to a use-after-free error that is triggered when creating SSL/TLS wrapped NDMP sessions. An unauthenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code with SYSTEM level privileges.


Upgrade to Veritas Backup Exec Remote Agent version 14.1.1786.1126 / 14.2.1180.3160 / 16.0.1142.1327, or later.

See Also

Plugin Details

Severity: Critical

ID: 101294

File Name: veritas_backup_exec_remote_agent_VTS17-006.nasl

Version: $Revision: 1.3 $

Type: local

Agent: windows

Family: Windows

Published: 2017/07/07

Modified: 2017/08/16

Dependencies: 101295

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:veritas:backup_exec_remote_agent

Required KB Items: installed_sw/Veritas Backup Exec Remote Agent, SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/05/10

Vulnerability Publication Date: 2017/05/10

Exploitable With

Metasploit (Veritas/Symantec Backup Exec SSL NDMP Connection Use-After-Free)

Reference Information

CVE: CVE-2017-8895

BID: 98386

OSVDB: 157380

EDB-ID: 42282

IAVA: 2017-A-0197