IMail IMAP Server Login Functions Remote Overflow

High Nessus Plugin ID 10123


The remote IMAP server is affected by a buffer overflow vulnerability.


The remote host is running IMail IMAP server. The installed version is affected by a buffer overflow when handling a long user name, or a long password. An attacker, exploiting this flaw, could cause a denial of service, or possibly execute arbitrary code subject to the permissions of the IMAP server.


Upgrade to IMail 5.0.3 or later.

See Also

Plugin Details

Severity: High

ID: 10123

File Name: imail_imapd_overflow.nasl

Version: $Revision: 1.31 $

Type: remote

Published: 1999/06/22

Modified: 2014/07/14

Dependencies: 10125, 17975

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

Vulnerability Information

Excluded KB Items: imap/false_imap, imap/overflow

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 1999/03/01

Reference Information

CVE: CVE-1999-1557

BID: 502

OSVDB: 10842