Debian DLA-1011-1 : sudo security update

High Nessus Plugin ID 101210

Synopsis

The remote Debian host is missing a security update.

Description

Todd Miller's sudo version 1.8.20p1 and earlier is vulnerable to an input validation (embedded newlines) in the get_process_ttyname() function resulting in information disclosure and command execution.

The previous announcement (DLA-970-1) was about a similar security issue (CVE-2017-1000367) which wasn't completely fixed.

For Debian 7 'Wheezy', these problems have been fixed in version 1.8.5p2-1+nmu3+deb7u4.

We recommend that you upgrade your sudo packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected sudo, and sudo-ldap packages.

See Also

https://lists.debian.org/debian-lts-announce/2017/07/msg00004.html

https://packages.debian.org/source/wheezy/sudo

Plugin Details

Severity: High

ID: 101210

File Name: debian_DLA-1011.nasl

Version: 3.8

Type: local

Agent: unix

Published: 2017/07/05

Updated: 2018/07/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:sudo, p-cpe:/a:debian:debian_linux:sudo-ldap, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/07/03

Reference Information

CVE: CVE-2017-1000368