Telerik UI for ASP.NET AJAX Cryptographic Weakness

High Nessus Plugin ID 101159

Synopsis

A web application development suite installed on the Windows remote host is affected by a cryptographic weakness.

Description

The version of Telerik UI for ASP.NET AJAX installed on the remote Windows host is affected by a cryptographic weakness in Telerik.Web.UI.dll. An unauthenticated, remote attacker can exploit this, via specially crafted data, to disclose encryption keys.

Solution

Upgrade to Telerik UI for ASP.NET AJAX version R2 2017 SP1 (2017.2.621) or later.

See Also

http://www.nessus.org/u?4efdcfeb

http://www.nessus.org/u?3e5e7456

Plugin Details

Severity: High

ID: 101159

File Name: telerik_ui_for_aspnet_ajax_CVE-2017-9248.nasl

Version: 1.8

Type: local

Agent: windows

Family: Windows

Published: 2017/06/30

Updated: 2019/11/12

Dependencies: 101160

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-9248

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:telerik:ui_for_asp.net_ajax

Required KB Items: installed_sw/Telerik UI for ASP.NET AJAX

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/06/21

Vulnerability Publication Date: 2017/06/26

Reference Information

CVE: CVE-2017-9248