RHEL 7 : freeradius (RHSA-2017:1581)

High Nessus Plugin ID 101078


The remote Red Hat host is missing one or more security updates.


An update for freeradius is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

FreeRADIUS is a high-performance and highly configurable free Remote Authentication Dial In User Service (RADIUS) server, designed to allow centralized authentication and authorization for a network.

Security Fix(es) :

* An authentication bypass flaw was found in the way the EAP module in FreeRADIUS handled TLS session resumption. A remote unauthenticated attacker could potentially use this flaw to bypass the inner authentication check in FreeRADIUS by resuming an older unauthenticated TLS session. (CVE-2017-9148)


Update the affected packages.

See Also



Plugin Details

Severity: High

ID: 101078

File Name: redhat-RHSA-2017-1581.nasl

Version: $Revision: 3.4 $

Type: local

Agent: unix

Published: 2017/06/28

Modified: 2018/01/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:freeradius, p-cpe:/a:redhat:enterprise_linux:freeradius-debuginfo, p-cpe:/a:redhat:enterprise_linux:freeradius-devel, p-cpe:/a:redhat:enterprise_linux:freeradius-doc, p-cpe:/a:redhat:enterprise_linux:freeradius-krb5, p-cpe:/a:redhat:enterprise_linux:freeradius-ldap, p-cpe:/a:redhat:enterprise_linux:freeradius-mysql, p-cpe:/a:redhat:enterprise_linux:freeradius-perl, p-cpe:/a:redhat:enterprise_linux:freeradius-postgresql, p-cpe:/a:redhat:enterprise_linux:freeradius-python, p-cpe:/a:redhat:enterprise_linux:freeradius-sqlite, p-cpe:/a:redhat:enterprise_linux:freeradius-unixODBC, p-cpe:/a:redhat:enterprise_linux:freeradius-utils, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/06/28

Reference Information

CVE: CVE-2017-9148

OSVDB: 158200

RHSA: 2017:1581